[gelöst] WLAN Abbrüche



  • Mein airQ steht ca. 4-5 m entfernt vom WLAN-Router. Die Verbindung sollte also bestens sein.
    Trotzdem beobachte ich folgende Probleme:

    1. Alle 2-3 Tage bricht der WLAN-Kontakt vollständig ab. Die unteren 2 LEDs am airQ leuchten lila.
      Der airQ meldet sich auch nicht mehr im WLAN an. Andere WLAN-Geräte arbeiten gleichzeitig völlig problemlos.
      In Folge bekomme ich in der App und in der Cloud auch keine aktuellen Werte mehr.
      Schalte ich den airQ aus und wieder an, funktioniert alles wieder bestens.
      Da ich häufig auch mehrere Tage nicht in der Nähe des airQ bin, ist das ein richtiges Problem.
      Ich helfe mir jetzt mit einer WLAN-Schaltsteckdose, was aber wohl kaum eine Dauerlösung sein sollte.

    2. Ich habe deshalb auch mal den Log des WLAN-Routers (FritzBox) angeschaut.
      In unregelmäßigen Abständen (10min. - 2h) taucht immer wieder auf: "WLAN-Gerät wurde abgemeldet" und ca. 3-5 sek. später "WLAN-Gerät wurde angemeldet". Und klar beim oben beschrieben Ausfall kommt nur "WLAN-Gerät wurde abgemeldet". Danach ist vom airQ in der Log-Datei nichts mehr zu sehen. Ansonsten taucht im Log des WLAN-Routers nichts außergewöhnliches auf.
      Ungefähr zeitgleich stehen im airQ-Log "Error 1.53 main overwatch loop detected that the main loop timed out (POS:6.5): machine restarted". Nach dem oben beschriebenen Ausfall kommen keine weiteren Einträge.

    Anmerkung: Nicht unerwähnt möchte ich lassen. Der airQ puffert die Daten und nach dem Neustart werden die fehlenden Daten in der Cloud nachgetragen. Es gehen also keine Daten verloren.



  • Kann es sein, dass die WLAN Verbindung zu schwach ist? In dem Fall trennt der air-Q die Verbindung, um sich anschliessend neu zu verbinden.

    Der Reboot ist im Moment normal und von uns so programmiert, um freezes zu vermeiden. Wir lösen dies mit zukünftigen Softwareupdates auf, welche noch fehlende Funktionen ergänzen.
    Es gehen ja keine Daten verloren - nichtmal eine Lücke in den aufgezeichneten Messwerten sollte zu erkennen sein.



  • Der airQ steht ca. 4-5 m vom Router entfernt, d.h. die WLAN-Stärke ist mehr als ausreichend. Zudem stehen etwas weiter entfernt 5 ESP8266 (eigen programmierte Sensoren), die zeigen keinerlei Schwierigkeiten.

    Die Ursache der WLAN-Abbrüche habe ich gefunden. Die im Router protokollierten Ereignis decken sich mit den Log-Einträgen "overwatch loop detected that the main loop timed out (POS:6.5): machine restarted" im Log des airQ.
    Klar wenn der airQ restarted bricht auch die WLAN Verbindung ab. Und das Problem "machine restarted" ist ja schon bekannt und Ihr habt hoffentlich bald eine Lösung.

    ABER keine Erklärung habe ich für "2. Alle 2-3 Tage bricht der WLAN-Kontakt vollständig ab....": Heute ist das wieder passiert. Da hilft dann nur Ausschalten/Einschalten.
    Das ist recht ärgerlich, da ich ja nicht dauernd neben dem airQ sitze und aufpasse.



  • @Micha
    Leider ist mir das Thema entgangen. Es gab aber seit dem einige Software updates.
    Besteht das Problem noch?



  • @Hallo Mario-air-Q
    das ist jetzt mindestens seit 1 Monat nicht mehr aufgetreten. Es kann damit zusammenhängen, dass ich MQTT aktuell nicht mehr einsetze.



  • Moin Mario und Micha,
    kann es sein, dass Du mehrere WLAN-Sender verwendest.
    Habe mich auch schon gewundert, warum es manchmal sehr wackelig ist, obwohl der AP nur wenige Meter entfernt ist.
    Heute nach dem Update auf die 1.64 war es besonders schlimm, weil er direkt nach dem Neustart nicht mehr sichtbar war und dann als Hotspot auftauchte.
    Nach mehren Neustarts ging es dann doch und ich konnte ermitteln, dass der air-q sich meistens in den ca. 25m entfernten AP einbuchte.
    Dann natürlich nur mit -91dB Signalstärke.
    Der 25m entfernte Sender ist auf Kanal 1, der 3m entfernte auf Kanal 6.
    Kann es sein, dass hier nicht erst das ganze Band gescannt wird sondern der erste gefundene, viel schwächere AP genommen wird?
    So extrem wie heute ist es mir mit den FW < 1.64 nie aufgefallen



  • @Pots
    Seit meinem letzten Post oben läuft es bei mir stabil, seit gut 14 Tagen auch wieder mit MQTT ohne Probleme.
    Ich habe nur einen Access-Point.



  • Hi zusammen, ich muss mich diesem Thema leider anschließen.
    Ich habe 2 Air-Qs und der eine davon verliert ständig das WLAN, und sendet dementsprechend auch keine MQTT Daten mehr.
    Nach einem Neustart (Vom Strom trennen) geht es dann meistens wieder, aber nur für ein paar Minuten. Manchmal verbindet er sich danach garnicht und ich muss nochmal neustarten.
    Gibt es hier Ideen woran das liegen könnte / was zu prüfen ist?



  • Hallo @hendrik_sb,
    bei mir läuft der air-Q jetzt schon lange sehr stabil im WLAN, aber ich erinnere mich noch gut wie ärgerlich diese WLAN-Abbrüche immer waren.
    Also ich würde jetzt als erstes die Logs prüfen:

    Was habe ich damals noch gemacht:
    Mein Router eine Fritz!Box kennt beim WLAN-Kanal die Einstellung "AutoKanal". Mit dieser Einstellung wechselt die Fritz!Box den WLAN-Kanal wenn der bestehende Kanal mehrfach belegt ist und andere Kanäle frei sind. Ich hatte damals den Eindruck, dass die WLAN-Abbrüche manchmal (nicht immer) parallel zum Kanalwechsel stattfanden.

    Hast Du mehrere AccessPoints? Wenn ja, in welchen melden sich die beiden air-Qs an? Vielleicht besteht da ein Zusammenhang.
    Wie groß ist die Entfernung zwischen AccessPoint und air-Q? Welches Mauerwerk ist eventuell dazwischen? Oder noch besser, kannst Du z.B. mit einem SmartPhone die Signalstärke beim air-Q messen?

    -> @Mario-air-Q: Die WLAN-Stärke der sichtbaren APs am air-Q messen und über den Miniwebserver sichtbar machen wäre eine tolle und eigentlich recht einfache Erweiterung für den air-Q.



  • Hallo @hendrik_sb
    das gleiche Problem hatte ich vor einiger Zeit mit einem älteren Powerline/WLAN Adapter von CLS. Trotz stabilem WLAN-Signal Abbruch und erst nach Netz-Aus wieder eine Verbindung. Allerdings hatte das Smartphone auch häufiger ein Verbindungsproblem. Nach Austausch gegen ein TP-Link traten die Probleme nicht mehr auf.
    Vor ein paar Wochen aber ein ganz neues Phänomen/Problem. Die air-Q Daten wurden nicht mehr in die Cloud übertragen. Das fiel aber mit Arbeiten an der Cloud zusammen. Siehe meinen Beitrag:
    @FreshAire [gelöst] AirQ&#x60;s doppelt in der Cloud (Online) vorhanden

    Tage danach trat das Problem allerdings wieder häufiger auf. Mehrfach keine Daten in der Cloud, dann wieder alles vorhanden. Aber der Zugang zum air-Q über LAN und Gerätemanager waren problemlos möglich. Auch waren alle gespeicherten Werte vorhanden und ließen sich problemlos runterladen.
    Ein Blick in die "Konfiguration & Geräteinfos" zeigte: WLANsignal: -91 cloudUpload: true
    Zufällig bemerkte ich dann einmal die Fehler-LED für WLAN. Verschwand mit dem Aufruf des Gerätemanagers der sich mit dem airQ dann verband. Nach Wechsel an einen neuen Standort keine Probleme mehr, jetzt WLANsignal -78
    Der in der Geräteinfo angezeigte Wert ist aber nicht der aktuelle Wert, sondern der Wert zum Zeitpunkt des letzten Verbindungsaufbaus. So stand es jedenfalls mal im Forum.
    Vielleicht hilft es ja weiter.



  • Hallo @FreshAire,
    "Ein Blick in die "Konfiguration & Geräteinfos" zeigte: WLANsignal: -91 cloudUpload: true": Danke! Ich wusste noch gar nicht, dass man das schon in der Config sieht.



  • Danke für eure Antworten.
    Anahnd von gesendeten MQTT Daten kann ich sehen dass die Verbindung bereits einmal (kurz) geklappt (Sowie auch die Übertragung von MQTT Daten). Ich habe den Air-Q nun einmal vom Netz genommen und in den Log geschaut:

    2021-02-18T17:10:39+00:00 Error 1.68 main Could not send updated config to AWS - Type: ; Reason: sendAWS
    2021-02-18T17:10:41+00:00 Error 1.68 main Could not send updated config to AWS - Type: ; Reason: sendAWS
    2021-02-18T17:10:43+00:00 Error 1.68 main Could not send updated config to AWS - Type: ; Reason: sendAWS
    2021-02-18T17:10:45+00:00 Error 1.68 main Could not send updated config to AWS - Type: ; Reason: sendAWS
    2021-02-18T17:20:55+00:00 Error 1.68 main main() loop run failed (POS:7.5) - Type: ; Reason: health

    Das war alles was da drin stand.
    Nach dem wiederanschließen taucht der Air-Q bei mir am Router wieder korrekt auf, im richtigen WLAN und Verbindungstyp. Er sendet keine MQTT Daten und verschwindet nach ca. 2-3 Minunten wieder aus der Geräteliste am Router (Unifi). Der Empfang am Aufstellort ist hervorragend (Smartphone volles WLAN Signal), es sind keiner Wände dazwischen.


Log in to reply